Forge 1.19 Server Log

#xQgTF6q
2 errors
69 lines
Analysis
Minecraft version:
1.19
Forge version:
41.0.63
Java version:
17.0.2
The mod 'cfm' is missing the required mod 'forge'.
Line #12
Solutions
Install the mod 'forge' with version 41.0.94.
1[16Jul2022 22:06:27.065] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--launchTarget, forgeserver, --fml.forgeVersion, 41.0.63, --fml.mcVersion, 1.19, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20220607.102129, nogui]
2[16Jul2022 22:06:27.102] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 10.0.1+10.0.1+main.e9521dc3 starting: java version 17.0.2 by Oracle Corporation; OS Linux arch amd64 version 5.4.0-109-generic
3[16Jul2022 22:06:27.710] [main/INFO] [mixin/]: SpongePowered MIXIN Subsystem Version=0.8.5 Source=union:/server/libraries/org/spongepowered/mixin/0.8.5/mixin-0.8.5.jar%2362!/ Service=ModLauncher Env=SERVER
4[16Jul2022 22:06:28.392] [main/WARN] [net.minecraftforge.fml.loading.moddiscovery.ModFileParser/LOADING]: Mod file /server/libraries/net/minecraftforge/fmlcore/1.19-41.0.63/fmlcore-1.19-41.0.63.jar is missing mods.toml file
5[16Jul2022 22:06:28.446] [main/WARN] [net.minecraftforge.fml.loading.moddiscovery.ModFileParser/LOADING]: Mod file /server/libraries/net/minecraftforge/javafmllanguage/1.19-41.0.63/javafmllanguage-1.19-41.0.63.jar is missing mods.toml file
6[16Jul2022 22:06:28.448] [main/WARN] [net.minecraftforge.fml.loading.moddiscovery.ModFileParser/LOADING]: Mod file /server/libraries/net/minecraftforge/lowcodelanguage/1.19-41.0.63/lowcodelanguage-1.19-41.0.63.jar is missing mods.toml file
7[16Jul2022 22:06:28.451] [main/WARN] [net.minecraftforge.fml.loading.moddiscovery.ModFileParser/LOADING]: Mod file /server/libraries/net/minecraftforge/mclanguage/1.19-41.0.63/mclanguage-1.19-41.0.63.jar is missing mods.toml file
8[16Jul2022 22:06:28.588] [main/INFO] [net.minecraftforge.fml.loading.moddiscovery.JarInJarDependencyLocator/]: No dependencies to load found. Skipping!
9[16Jul2022 22:06:28.690] [main/ERROR] [net.minecraftforge.fml.loading.ModSorter/LOADING]: Missing mandatory dependencies: forge
10[16Jul2022 22:06:32.747] [main/INFO] [cpw.mods.modlauncher.LaunchServiceHandler/MODLAUNCHER]: Launching target 'forgeserver' with arguments [nogui]
11[16Jul2022 22:06:38.703] [main/INFO] [net.minecraft.util.datafix.DataFixers/]: Building unoptimized datafixer
12[16Jul2022 22:06:42.049] [main/FATAL] [net.minecraftforge.fml.ModLoader/CORE]: Error during pre-loading phase
13net.minecraftforge.fml.ModLoadingException: Mod §ecfm§r requires §6forge§r §o41.0.94 or above§r
14§7Currently, §6forge§r§7 is §o41.0.63
15 at net.minecraftforge.fml.ModLoadingException.lambda$fromEarlyException$0(ModLoadingException.java:50) ~[fmlcore-1.19-41.0.63.jar%2398!/:?]
16 at java.util.stream.ReferencePipeline$3$1.accept(ReferencePipeline.java:197) ~[?:?]
17 at java.util.AbstractList$RandomAccessSpliterator.forEachRemaining(AbstractList.java:720) ~[?:?]
18 at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:509) ~[?:?]
19 at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:499) ~[?:?]
20 at java.util.stream.ForEachOps$ForEachOp.evaluateSequential(ForEachOps.java:150) ~[?:?]
21 at java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(ForEachOps.java:173) ~[?:?]
22 at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234) ~[?:?]
23 at java.util.stream.ReferencePipeline.forEach(ReferencePipeline.java:596) ~[?:?]
24 at java.util.stream.ReferencePipeline$7$1.accept(ReferencePipeline.java:276) ~[?:?]
25 at java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1625) ~[?:?]
26 at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:509) ~[?:?]
27 at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:499) ~[?:?]
28 at java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java:921) ~[?:?]
29 at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234) ~[?:?]
30 at java.util.stream.ReferencePipeline.collect(ReferencePipeline.java:682) ~[?:?]
31 at net.minecraftforge.fml.ModLoader.<init>(ModLoader.java:99) ~[fmlcore-1.19-41.0.63.jar%2398!/:?]
32 at net.minecraftforge.fml.ModLoader.get(ModLoader.java:131) ~[fmlcore-1.19-41.0.63.jar%2398!/:?]
33 at net.minecraftforge.server.loading.ServerModLoader.load(ServerModLoader.java:32) ~[forge-1.19-41.0.63-universal.jar%23102!/:?]
34 at net.minecraft.server.Main.main(Main.java:113) ~[server-1.19-20220607.102129-srg.jar%2397!/:?]
35 at jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:?]
36 at jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:77) ~[?:?]
37 at jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:?]
38 at java.lang.reflect.Method.invoke(Method.java:568) ~[?:?]
39 at net.minecraftforge.fml.loading.targets.CommonServerLaunchHandler.lambda$launchService$0(CommonServerLaunchHandler.java:29) ~[fmlloader-1.19-41.0.63.jar%2365!/:?]
40 at cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:30) [modlauncher-10.0.1.jar%2353!/:?]
41 at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:53) [modlauncher-10.0.1.jar%2353!/:?]
42 at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:71) [modlauncher-10.0.1.jar%2353!/:?]
43 at cpw.mods.modlauncher.Launcher.run(Launcher.java:106) [modlauncher-10.0.1.jar%2353!/:?]
44 at cpw.mods.modlauncher.Launcher.main(Launcher.java:77) [modlauncher-10.0.1.jar%2353!/:?]
45 at cpw.mods.modlauncher.BootstrapLaunchConsumer.accept(BootstrapLaunchConsumer.java:26) [modlauncher-10.0.1.jar%2353!/:?]
46 at cpw.mods.modlauncher.BootstrapLaunchConsumer.accept(BootstrapLaunchConsumer.java:23) [modlauncher-10.0.1.jar%2353!/:?]
47 at cpw.mods.bootstraplauncher.BootstrapLauncher.main(BootstrapLauncher.java:141) [bootstraplauncher-1.1.1.jar:?]
48[16Jul2022 22:06:42.199] [main/FATAL] [net.minecraftforge.server.loading.ServerModLoader/]: Crash report saved to ./crash-reports/crash-2022-07-16_22.06.42-fml.txt
49[16Jul2022 22:06:42.206] [main/ERROR] [net.minecraft.server.Main/FATAL]: Failed to start the minecraft server
50net.minecraftforge.fml.LoadingFailedException: Loading errors encountered: [
51 Mod §ecfm§r requires §6forge§r §o41.0.94 or above§r
52§7Currently, §6forge§r§7 is §o41.0.63
53]
54 at net.minecraftforge.fml.ModLoader.gatherAndInitializeMods(ModLoader.java:152) ~[fmlcore-1.19-41.0.63.jar%2398!/:?]
55 at net.minecraftforge.server.loading.ServerModLoader.load(ServerModLoader.java:32) ~[forge-1.19-41.0.63-universal.jar%23102!/:?]
56 at net.minecraft.server.Main.main(Main.java:113) ~[server-1.19-20220607.102129-srg.jar%2397!/:?]
57 at jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:?]
58 at jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:77) ~[?:?]
59 at jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:?]
60 at java.lang.reflect.Method.invoke(Method.java:568) ~[?:?]
61 at net.minecraftforge.fml.loading.targets.CommonServerLaunchHandler.lambda$launchService$0(CommonServerLaunchHandler.java:29) ~[fmlloader-1.19-41.0.63.jar%2365!/:?]
62 at cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:30) [modlauncher-10.0.1.jar%2353!/:?]
63 at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:53) [modlauncher-10.0.1.jar%2353!/:?]
64 at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:71) [modlauncher-10.0.1.jar%2353!/:?]
65 at cpw.mods.modlauncher.Launcher.run(Launcher.java:106) [modlauncher-10.0.1.jar%2353!/:?]
66 at cpw.mods.modlauncher.Launcher.main(Launcher.java:77) [modlauncher-10.0.1.jar%2353!/:?]
67 at cpw.mods.modlauncher.BootstrapLaunchConsumer.accept(BootstrapLaunchConsumer.java:26) [modlauncher-10.0.1.jar%2353!/:?]
68 at cpw.mods.modlauncher.BootstrapLaunchConsumer.accept(BootstrapLaunchConsumer.java:23) [modlauncher-10.0.1.jar%2353!/:?]
69 at cpw.mods.bootstraplauncher.BootstrapLauncher.main(BootstrapLauncher.java:141) [bootstraplauncher-1.1.1.jar:?]
This log will be saved for 90 days from their last view.
Report abuse